Office365のWord2016(バージョン16.x)でEndNote X7のアドインが使えなくなったので削除する方法

どーも、最近おもしろいことが多くてついつい夜遅くなり、絶賛寝不足中のまーくです。

Word2016 を使うようになってしばらく経つのですが、年明け頃頻繁に出てきて気になっていた問題がしばらく前に無事解決できたので記録のために残しておきます。

環境は、MacBook Pro (macOS High Sierra)です。

Wordを開く度に現れる「アドインを読み込むことができませんでした」

こいつが出てきます。

「アドインを読み込むことができませんでした。アドインは、このバージョンの Word と互換性がありません。更新について、アドインの提供元にお問い合わせください。(EndNote CWYW Word 2016.bundle)」

文献管理にEndNoteを入れていたのですが、古い X7 は Word2016でサポートされなくなってしまったので毎回エラーがでるようになったのです。

Google先生に「word2016 アドイン 削除」などと聞いて出てくるサイト(主にMicrosoftのページやそれに倣った個人サイトなんですが)を見ても全く解決できず。

そのようなサイトでは、「アドインの管理画面を開いてチェックマークを外せば良い」と書いてありますが、そもそも項目がグレーアウトしていて触ることができません!

他には、新しいEndNote X8にアップグレードするか、wordをダウングレードすると書いてあったりしますが、バグやセキュリティホールを持った状態で使うのは論外(という性格)です。

Q:Word 2016 バージョン16.xでアドインが使用できなくなった 

で、あれこれ調べて、ようやくたどり着いた方法がこちらです!

 

解決方法

答えはシンプルでした。

  1. EndNote X7をあきらめる
  2. ターミナルを開いて以下のコマンドを実行する
mv /Library/Application\ Support/Microsoft/Office365/User\ Content.localized/Startup.localized/Word/EndNote\ CWYW\ Word\ 2016.bundle/ ~/Desktop/

ああ、スッキリ!

このbundleを消せば良いという考えににたどり着くまでが長かった。。。

上のコマンドは念のためデスクトップに移動してますが、rmやFindeでゴミ箱に捨てても同じです。

おまけ

ちなみに、文献管理は現在「Mendeley」に落ち着いています。

 

 

D003